Commit 00bb2b09 authored by Lukas Riedel's avatar Lukas Riedel

Update README.md

- Add yaml-cpp to dependencies
- Update installation instructions
parent b0b78f81
......@@ -64,6 +64,7 @@ by CI tests.
| pip | 3.6 |
| MPI | | Tested with OpenMPI 2.1.1
| SuperLU | 5.2 |
| [yaml-cpp](https://github.com/jbeder/yaml-cpp) | >= 5.2.0 |
| [dune-common](https://gitlab.dune-project.org/core/dune-common) | releases/2.6
| [dune-geometry](https://gitlab.dune-project.org/core/dune-geometry) | releases/2.6
| [dune-grid](https://gitlab.dune-project.org/core/dune-grid) | releases/2.6
......@@ -102,13 +103,14 @@ If you installed [Anaconda](https://conda.io/docs/user-guide/install/download.ht
apt install cmake doxygen gcc g++ gfortran \
git libatlas-base-dev libfftw3-dev libfftw3-mpi-dev \
libfreetype6-dev libhdf5-mpi-dev libopenmpi-dev libpng-dev \
libsuperlu-dev libxft-dev python3-dev python3-pip
libsuperlu-dev libyaml-cpp-dev libxft-dev \
python3-dev python3-pip
**macOS:**
brew update
brew install cmake doxygen gcc libpng open-mpi \
pkg-config python3 superlu
pkg-config python3 superlu yaml-cpp
brew install hdf5 --with-mpi
brew install fftw --with-mpi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment